Unable to connect bitmagic with Mac M1 pro

I have Ubuntu running on Parallels on mac m1 pro. Ubuntu is again ARM based similar to M1.

I haven’t tried using all the tools on an ARM mac, but had no trouble with an x86 mac using homebrew and on an ARM raspberry pi running ubuntu. I have not, however, had luck with virtualization with any combination of host and guest OSs - specifically the Bitmagic, because it uses the full bandwidth of the USB 2.0 link and usb passthrough can’t keep up.

What do you mean by ‘unable to connect’ though? Does the USB device show up in either OSX (system properties) or ubuntu (lsusb or dmesg)?

The bitmagic does have a unique initialization pattern:

  1. first, it shows up as a generic cypress device
  2. next, it gets a firmware loaded (fx2lafw) by the sigrok-firmware package
    3, finally, it restarts and shows up as the logic analyzer

there are some more details about different OSs in the course appendix: Applied Physical Attacks #1: Embedded and IoT Systems – SecuringHardware.com

Let me know how it goes - if you’re able to get it working or not, and how. There’s always the possibility you’ve got a bad bitmagic or bad cable, if that’s the case, also let me know and i’ll get you a replacement.

Instead of Ubuntu, I tried it with Kali with same setup and it worked fine.

Glad to hear you got it working! Let me know if anything else comes up.